Back to overview
Maintenance

Changing host location #2

May 2, 2026 at 11:44am UTC  –  May 2, 2026 at 1:44pm UTC
Affected services
itzcrih-panel
de-node-1
de-node-2

Resolved
May 2, 2026 at 1:44pm UTC

Maintenance ended

Created
May 2, 2026 at 11:44am UTC

Panel and game hosting currently unavaiable, we are changing the node location de-1 for better routing and performance.