Back to overview
Maintenance
Fixing YouTube API Downloader error
May 16, 2026 at 10:00pm UTC
–
May 18, 2026 at 9:48pm UTC
Affected services
downloader.itzcrih.it
Resolved
May 18, 2026 at 9:48pm UTC
Maintenance ended
Affected services
Created
May 16, 2026 at 10:00pm UTC
itzDownloader is currently inavailable as our YT Api broke. We are currently trying to fix this.
Affected services